TP-Link Router login error on Firefox


#1

I use my routers page frequently for parental control, but the macro to log in does not work after the password. It says the password is incorrect, although it is correct. I changed the part for click for sendkey command ($KEY_ENTER}, but it did not help. It seems that some way it detects the input is recorded. Also, is there a wait to input a command or type manually during play, and if so, can you suggest the commands to use? Thanks.

This is the log with password as password to not disclose it, and the URL address numbers changed, but the rest is the same.

[info]

Executing: | open | http://192.168.0.1/webpages/login.html?t=1234567891011 | |

[info]

Executing: | clickAt | css=#form-login > div.login-field > div > div > div.widget-wrap.text-wrap.password-wrap.allow-visible > span.hint.text-hint.password-hint > input | 75,16 |

[info]

Executing: | type | css=#form-login > div.login-field > div > div > div.widget-wrap.text-wrap.password-wrap.allow-visible > span.text-wrap.password-wrap > input.text-text.password-text.password-hidden.l | password |

[info]

Executing: | type | css=#form-login > div.login-field > div > div > div.widget-wrap.text-wrap.password-wrap.allow-visible > span.text-wrap.password-wrap > input.text-text.password-text.password-hidden.l | password |

[info]

Executing: | clickAt | css=#ul-nav > li:nth-child(3) > div > a > span | 39,16 |

[error]

time out when looking for element ‘css=#ul-nav > li:nth-child(3) > div > a > span’

[info]

Macro failed (Runtime 14.40s)


#2

If you are getting a router login error then try to refresh the page and clear the cookies. Sometimes because of the cookies stored in the pc, you get this error


#3

Router login problem you can try some

Clear the cache and the cookies from websites that cause problems.

Clear the Cache

Firefox/Tools > Options > Advanced > Network > Cached Web Content-Clear Now
“Remove Cookies” from sites causing problems:

Firefox/Tools > Options > Privacy > Cookies: “Show Cookies”
and rather than have any problem try Firefox Support for help.