No play tab found when i want to play a macro


#1

Hello , i am new in Kantu and i want to play a macro of demonstration : DemoCsvReadWithWhile
and i have a error when it wants to execute the command
while “${!csvReadStatus}” == "OK"
the error is : no play tab found .
I saw there was a post about this problem but it doesn’t help me

kind regards


#2

This error means that Kantu does not know in which browser tab to play the macro.

Do you get this error always, or “only” sometimes? Maybe you closed the tab to which Kantu was connected?


#3

use error ignore ,csv read ,If | ${!LastCommandOK} and loop instead while


#4

I have this problem every time and i have an only table


#5

did you try
{
“Command”: “selectWindow”,
“Target”: “tab=0”,
“Value”: “”
}


#6

I have still the same error message


#7

show us entire macro


#8

it is the demo DemoCsvReadWithWhile
{
“CreationDate”: “2018-10-30”,
“Commands”: [
{
“Command”: “store”,
“Target”: “180”,
“Value”: “!timeout_macro”
},
{
“Command”: “store”,
“Target”: “fast”,
“Value”: “!replayspeed”
},
{
“Command”: “comment”,
“Target”: “The file ReadCSVTestData.csv is pre-installed with Kantu.”,
“Value”: “”
},
{
“Command”: “csvRead”,
“Target”: “ReadCSVTestData.csv”,
“Value”: “”
},
{
“Command”: “echo”,
“Target”: “Status = ${!csvReadStatus}, line = ${!csvReadLineNumber}”,
“Value”: “”
},
{
“Command”: “while”,
“Target”: “”${!csvReadStatus}" == “OK”",
“Value”: “”
},
{
“Command”: “echo”,
“Target”: “status = ${!csvReadStatus}, line = ${!csvReadLineNumber}”,
“Value”: “”
},
{
“Command”: “open”,
“Target”: “https://docs.google.com/forms/d/e/1FAIpQLScGWVjexH2FNzJqPACzuzBLlTWMJHgLUHjxehtU-2cJxtu6VQ/viewform”,
“Value”: “”
},
{
“Command”: “type”,
“Target”: “name=entry.933434489”,
“Value”: “${!COL1}_${!csvReadLineNumber}”
},
{
“Command”: “type”,
“Target”: “name=entry.2004105717”,
“Value”: “${!COL2}”
},
{
“Command”: “type”,
“Target”: “name=entry.1382578664”,
“Value”: “${!COL3}”
},
{
“Command”: “clickAndWait”,
“Target”: “//*[@id=“mG61Hd”]/div/div[2]/div[3]/div[1]/div/div/content/span”,
“Value”: “”
},
{
“Command”: “storeEval”,
“Target”: “${!csvReadLineNumber}+1”,
“Value”: “!csvReadLineNumber”
},
{
“Command”: “store”,
“Target”: “true”,
“Value”: “!errorIgnore”
},
{
“Command”: “echo”,
“Target”: "Reading CSV line No. ${!csvReadLineNumber} ",
“Value”: “!errorIgnore”
},
{
“Command”: “csvRead”,
“Target”: “ReadCSVTestData.csv”,
“Value”: “”
},
{
“Command”: “store”,
“Target”: “false”,
“Value”: “!errorIgnore”
},
{
“Command”: “endWhile”,
“Target”: “”,
“Value”: “”
}
]
}


#9

that demo macro works fine
try restarting your pc


#10

i restart my pc , i have still the same error message


#11

try while “${!csvReadStatus}” = "OK"
instead
while “${!csvReadStatus}” == "OK"


#12

I find the problem , i launch the macro DemoCsvReadWithWhile in a tab without url address , the macro doesn’t work.
When i fill an url address (anyone) , i launch the macro and it works.
But when i launched other macros on a tab without url address , i didn’t have the problem.
Thank you for your help:smile:


#13

You have to open any page for selenium to work.