[Reproducer Required] [bug] xFile is not installed yet


#1

So now I can’t run scheduled scripts.
Kantu is getting more and more fun (not).

I’m updating my list.

To predict the question. I have reinstalled xModules. Didn’t help.
And this error doesn’t show up if I run scripts manually.


#2

This is a good hint. XModules are installed for the user (like Chrome). So do you run Kantu under the same user account that you use manually?


#3

Yes. And I was running scheduled scripts successfully until recently (few days I believe).


#4

Ouch. This is strange then. There was no Kantu update the last days.

How do you schedule the scripts? task scheduler?


#5

I know :smile:

Ahha. Win 8.1 x64 Chrome 70.0.3538.102 x64


#6

BTW I do not use Chrome for anything except Kantu. It’s my guinea pig for it if you will.


#7

I have launched several times from the task scheduler receiving this error.
Once I launched html from folder and the error did not show up.
Now it doesn’t show up when I run from scheduler as well.
But I know for a fact it will show up again sometime soon (today is not the first day).

Kantu is more & more like a Flying Dutchman to me.

Guys you really need to make a tool for debugging this beast.


#8

Aaaand… it’s back. LOL. :laughing:


#9

We just fixed a maybe related issue for the command line (sometimes settings are not loaded in time). There is a good chance that this also fixes this issue. Please report back after the next upgrade.

The beta channel will be updated tomorrow already, and the production version probably next week.

I agree about the need for a debug log option.


#10

Beta Updated. Thanks guys?!

XModules Status: Free Edition
Only the first 10 files displayed.
Upgrade to PRO to add more.


#11

This limit applies only the XModules direct file access. In the standard HTML5 storage mode, Kantu continues to support unlimited macros and testsuites.


#12

Thanks for testing the beta. Please let me know if you continue to see the error with the new version - I hope not :wink:


#13

I see new ones. When I open script exactly five (5) windows of Kantu open up.
I close all of them. Reload the page with kantu test suite. And again 5 windows of Kantu.
It was like that until I restarted the browser.
But after restart xFile appeared again. Sad day. (


#14

And a new one:

Boy this is fun! :grin:


#15

My guess. Something in Kantu loads ahead of the time and boom… there goes an error of any kind.


#16

Thanks for the feedback. We will be testing this further.

How do you call the command line? From a batch file, powershell, task scheduler… ?


#17

Windows task scheduler.


#18

I can confirm that this error occurred for me after I installed XModules, changed the home folder location to C:\User\USERNAME\Documents\Kantu, and clicked ‘Test it’.

However, after closing Kantu and re-opening, Test it doesn’t report an error. I should add that I also copied the sub-folders to the new location, too (datasources, images, macros etc.)

I’ve not actually tested the module yet (I’m a new user).