Kantu keeps stopping at the same command


#1

Hi guys,

I’ve previously tried to get this problem solved but without success.

I have a simple macro, that is supposed to type text into a text box.

Unfortunately this barley ever works - the confusing part is, sometimes it does (1 out of 100 times it works)

I set up a test account for usage.

Please use provided details to log in to the following website:
URL: http://assessment.atec.edu.au/

Username: stephanie@qams.com.au
Password: Kantu2018

Once logged in click on the course under “My Topics” (Remove Non Friable Asbestos)
From the menu that drops down click on “1 Underpinning Knowledge” and the first question pops up.

Question: Explain where you would find information about the safe work procedures on how to remove asbestos for a particular job.

The macro should now paste the answer into the provided text box and click save button, what then will open the next question and so on and on.

This is the macro I am using:

{
  "Command": "selectFrame",
  "Target": "index=0",
  "Value": ""
},
{
  "Command": "editContent",
  "Target": "/html/body",
  "Value": "THIS IS THE TEXT TO BE ENTERED"
},
{
  "Command": "selectFrame",
  "Target": "relative=top",
  "Value": ""
},
{
  "Command": "clickAndWait",
  "Target": "id=btnSave2",
  "Value": ""
},

Unfortunately it always stops at the command:

{
  "Command": "editContent",
  "Target": "/html/body",
  "Value": "THIS IS THE TEXT TO BE ENTERED"
},

I can then click in Kantu on “run this command” and it works, but if the macro repeats its steps it keeps stopping.

Please refer to post: Kantu keeps stopping at the same target

I have previously inquired about this issue without any success so far.

Thanks for any advise and help!


#2

As I still dont have a solution to this problem I uploaded a video of what is happening.

Download Video

Hoping for anyone to give me a hint what the issue is.


#3

Thanks for the video. So just to clarify: The macro stops at the command - but there is no error message? It just stays at the command forever?


#4

Same issue for me. Kantu opens a browser url with XML payload in it and stops there indefinitely. Please let me know how to resolve this.


#5

@macflare …indeed, this sounds like the same issue. Do you have a test URL for us? That would be helpful for debugging


#6

Unfortunately I do not have a test URL but the command opens a webpage with only XML payload in it and gets stuck. I believe it doesn’t understand if the page is completely opened since it’s only a XML payload?


#7

Ok. If it would work… what would you like to do (= automate) with the XML page?


#8

I would like to download the XML payload in to a file and then go back to the previous page.


#9

No there is an error message I just have the time set to 99999 I will. So I stop it myself.

Now I am trying and it’s working… (as I said sometimes it works and sometimes / most of the times it doesn’t what is the odd thing)

It stopped now at a different point that usual works though.

[info]
Executing:  | click | id=txtDocumentName |  | 
[error]
timeout reached when looking for element 'id=txtDocumentName'
[info]
Macro failed (Runtime 104.75s)

I will try to get the error message I am receiving for the “body” part that causes me the most problems and post it as soon I have something.


#10

Alright here we go:

I copied a little bit more so you can see it is the same command over and over again until it stops. I can then just click the button “Execute this command” or Run from here" and it will pick it up again.

[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | click | /html/body/p |  | 
[info]
Executing:  | editContent | /html/body | <div>1.<span style="white-space:pre"> </span>ultra violet.</div><div>2.<span style="white-space:pre"> </span>welding arc flashes.</div><div>3.<span style="white-space:pre"> </span>micro waves.</div><div>4.<span style="white-space:pre"> </span>lasers.</div> | 
[info]
Executing:  | selectFrame | relative=top |  | 
[info]
Executing:  | clickAndWait | id=btnSave2 |  | 
[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | click | /html/body/p |  | 
[info]
Executing:  | editContent | /html/body | <p>Asbestos &amp; Silica<br></p> | 
[info]
Executing:  | selectFrame | relative=top |  | 
[info]
Executing:  | clickAndWait | id=btnSave2 |  | 
[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | click | /html/body/p |  | 
[info]
Executing:  | editContent | /html/body | manufacture of glass, abrasives, concrete | 
[info]
Executing:  | selectFrame | relative=top |  | 
[info]
Executing:  | clickAndWait | id=btnSave2 |  | 
[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | click | /html/body/p |  | 
[error]
csPostMessage: timeout 60000 ms
[info]
Macro failed (Runtime 360.33s)

I then press “Run from here” and the macro picks up where it just stopped because of an error and continues just fine.

[status]
Playing macro 03_BSBWHS410 Contribute Work-Related Health Safety
[info]
Executing:  | click | /html/body/p |  | 
[info]
Executing:  | editContent | /html/body | <div>•<span style="white-space:pre"> </span>how severe a risk is.</div><div>•<span style="white-space:pre"> </span>whether any existing control measures are effective.</div><div>•<span style="white-space:pre"> </span>what action you should take to control the risk.</div><div>•<span style="white-space:pre"> </span>how urgently the action needs to be taken.</div> | 
[info]
Executing:  | selectFrame | relative=top |  | 
[info]
Executing:  | clickAndWait | id=btnSave2 |  | 
[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | editContent | /html/body | <div>•<span style="white-space:pre"> </span>confined spaces.</div><div>•<span style="white-space:pre"> </span>diving work.</div><div>•<span style="white-space:pre"> </span>live electrical work.</div> | 
[info]
Executing:  | selectFrame | relative=top |  | 
[info]
Executing:  | clickAndWait | id=btnSave2 |  |

#11

And another case same thing. Macro runs, stops, I click “Run from here” and it continues.

[status]
Playing macro 02_BSBWHS403 WHS Consultation and Participation - RECORDING ONLY
[info]
Executing:  | click | link=Contribute to Implementing and Maintaining WHS Consultation and Participation Processes |  | 
[info]
Executing:  | click | link=1 Assessment Task 1@POS=2 |  | 
[info]
Executing:  | selectFrame | index=0 |  | 
[error]
timeout reached when looking for frame 'index=0'
[info]
Macro failed (Runtime 100.80s)
[status]
Playing macro 02_BSBWHS403 WHS Consultation and Participation - RECORDING ONLY
[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | click | /html/body/p |  | 
[info]
Executing:  | editContent | /html/body | <p>-Persons conducting businesses or undertakings involving management or control of workplaces<br>-Persons conducting businesses or undertakings involving management or control of fixtures, fittings or plant at workplaces<br>-Persons conducting businesses or undertakings that design plant, substances or structures<br>-Persons conducting businesses or undertakings that manufacture plant, substances or<br>-Persons conducting businesses or undertakings that import plant, substances or structures<br>-Persons conducting businesses or undertakings that supply plant, substances or structures<br>-Persons conducting businesses or undertakings that install, construct or commission plant or structures<br></p> | 
[info]
Executing:  | selectFrame | relative=top |  | 
[info]
Executing:  | clickAndWait | id=btnSave2 |  |

#12

Any updates on this issue?


#13

We plan to have a fix for this at the end of this week.


#14

That would be amazing!

Same problem again with another macro:

[status]
Playing macro 07_JUST RECORDING WHILE COPY & PASTING
[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | editContent | /html/body | <p>Do not expose workers to airborne contaminants exceeding the exposure standard in the Regulations.<br></p> | 
[info]
Executing:  | selectFrame | relative=top |  | 
[info]
Executing:  | clickAndWait | id=btnSave2 |  | 
[info]
Executing:  | selectFrame | index=0 |  | 
[info]
Executing:  | editContent | /html/body | <div>•<span style="white-space:pre"> </span>When it is not clear whether airborne contaminants may exceed the exposure standard</div><div>•<span style="white-space:pre"> </span>When there may be a risk to health.</div> | 
[error]
csPostMessage: timeout 60000 ms
[info]
Macro failed (Runtime 73.56s)

Always getting “[error] csPostMessage: timeout 60000 ms”.


#15

What I am doing at the moment is simply pressing “pause” before the macro times out and then “continue” again. This way the macro runs through but I have to pause/continue all the time…


#16

Hi, just following up to see if there are any updates / news regarding this problem?


#17

We are working on it. It takes a bit longer than planned, but a new release should be ready soon, hopefully next week.


#18

Hi, I understand good things take time but I am just wondering if there is an update coming soon for this problem? It would be amazing!!


#19

A beta version that fixes this issue has been released last week.
=> see the last comment in this post for a download link:


#20

This issue has been fixed now with V3.1.6