Issue after update minimizing Kantu while macro is running


#1

Hello,

After the update if I minimize the Kantu window (on Chrome) while a macro is running I run into issues that were not present before. First the speed slows way down until i open Kantu again. Secondly, if i minimize the window it eventually will just stop. It doesn’t error out, it just stops at a random spot. Hitting pause and resume will get it going again but I’d really like to be able to minimize Kantu without these issues.


Kantu stops executing if other tabs are open in the same browser(chrome)
#2

I confirmed this regression issue - thanks for reporting it. We will try to fix this asap.


#3

Thanks for reporting this issue! It is fixed with V3.1.7 (released today)


#4

Hello,

Thank you for the quick response. Unfortunately I’m still seeing the slow down issue after the update today. It appears like it might now only be happening when it hits the section where i’m pulling from a CSV.

Additionally, i’m still having an issue where my (longer) macros will pause at random spots and I have to hit pause and resume to get them going again. This happens even when I don’t minimize the kantu window so it may be a separate issue?


#5

Hmm… can you recreate these remaining issues also with the included demo macros or another macro that you can paste here?

I tested with V3.1.8 and DemoCSVReadWithWhile demo macro and could not see any slow down when minimized. The runtime for this macro on my current machine/internet connection) was in both cases ~18s. Your runtime might be different, but it should be the same if run open or minimized. Kantu displays the overall runtime in the log tab.


#6

Mine was 17 seconds vs 18 seconds open/closed, which is very minimal. I can’t recreate the issues with the demos, but those are all very short compared to what i’m running. I’m reading several hundred lines from a csv, not just a couple lines. The pausing issue doesn’t seem to occur in any of the macros that it takes 10-20 seconds to run. But for this one it pauses at random spots after running for several minutes. And it was not doing this in the several months I’ve been using it prior to the update.

I can’t really paste the macro here without sending lengthy instructions and an additional spreadsheet, but basically I have hundreds of lines in a csv. I run this within a while loop to pull from the csv and enter into a text box, click a button, and as long as the last command was okay, keep doing that until the file is done.


#7

have you guys tried to run like 5 or more macros in a loop and minimize both “chrome browser window” and “kantu extension window” ? it seems to stop executing if both windows are minimized, but when either one of them is re-opened it continues the executing.

Can I conclude that to keep the loop running, we must have either “chrome browser window” or “kantu extension window” open/ not minimized?


#8

Do you see the problem also when running one of the included demo macros? I minimized both windows and all works still fine.


#9

See also the quesitons I asked here: Kantu stops executing if other tabs are open in the same browser(chrome) <= feel free to answer in this thread.

The key to fixing this issue is to find a test case that we can recreate.


#10

Hi Admin, thanks for your reply. I tried running the demo suites, you are right the demo suites working completely fine. That’s why I am confused, how come my test suit is not working(pauses/error) when I minimize both chrome and kantu window, while it works for the demo. If there are errors in the commands then it shouldn’t work when i have the windows maximized. I ran the same test suite I created multiple times, some with the windows open and some with windows minimized. However it only fails/stops when the browser and kantu window both minimized.

type of errors I get when both browser and kantu window minimized:

  1. element cannot be found (the element is found and works fine when either the browser or kantu window is open(maximized)
  2. just stops executing (purple in color)

some background information on my platform:

  1. using windows 10 (64-bit)
  2. Version 68.0.3440.106 (Official Build) (64-bit) - up to date as of now