Error at adaptor.ts when building


#1

Hi, i’m new at kantu and i had trouble building the src code form github when i downloaded it.
There was an error at first when i try to run npm run build and after a bit of searching i thought to update the version of webpack at package.json.
Now it’s actually starting to build but then an error appears:

ERROR in ./src/common/imagesearch/adaptor.ts
Module not found: Error: Can’t resolve ‘…/…/…/imagesearch-testextension/src/ts/image-helper’ in ‘C:\Kantu-master Backup copy\src\common\imagesearch’
@ ./src/common/imagesearch/adaptor.ts 5:23-88
@ ./src/ext/bg.js

ERROR in ./src/common/imagesearch/adaptor.ts
Module not found: Error: Can’t resolve ‘…/…/…/imagesearch-testextension/src/ts/job’ in ‘C:\Kantu-master Backup copy\src\common\imagesearch’
@ ./src/common/imagesearch/adaptor.ts 3:14-70
@ ./src/ext/bg.js

ERROR in ./src/common/imagesearch/adaptor.ts
Module not found: Error: Can’t resolve ‘…/…/…/imagesearch-testextension/src/ts/worker-connection’ in ‘C:\Kantu-master Backup copy\src\common\imagesearch’
@ ./src/common/imagesearch/adaptor.ts 4:28-98
@ ./src/ext/bg.js

am i missing something?


#2

also this link is dead:

https://github.com/A9T9/Kantu/tree/master/imagesearch-testextension/src/ts


#3

Yeah, the link is dead because " imagesearch-testextension" is an old test app that is no longer needed. So we removed it from the repo. Please delete it (or re-checkout kantu source) and then the build process should work.


#4

the newest from git doesn’t build without “imagesearch-testextension” apparently. adaptor.ts was looking for it. I actually was able to compile mine by taking a copy of imagesearch-testextension from an older version.