Error #101: Kantu is not connected to a browser tab


#1

I encounter the same problem on this thread [error] No Tab with id

  1. Navigate to the Webpage A
  2. Press “Search” Button
  3. Use “selectWindow” to focus on the Pop-up to search the result, and click on the result and pop up will close
  4. Navigate Webpage A again and continue (Failed)

When my pop up browser is closed, kantu not able to select the main webpage even i use selectWindow.

Error Message
Error #101: Kantu is not connected to a browser tab

Can anyone help on this ? i cant refresh the page or reload since save button is at the main webpage.


Macros don't work when Firefox is open the 1st time. Macros only work on 2nd or 3rd tab open
#2

Do you have a link to the website?


#3

Hi Ulrich,

I do not have link to show this is my backend website.
This is my last part to get the thing works, im stuck here hope you guys can help. Thanks

Owen


#4

A link to a website or, for internal websites, a screencast would be very helpful for us.


#5

I got today as well.

[error]

Error #101: Kantu is not connected to a browser tab


#6
  • Error #101: Kantu is not connected to a browser tab

I see the same error daily :frowning: its a pain :frowning:


#7

Is there a macro that I could use to recreate the error?

I get the error only if I manually close tabs by mistake, so that there is no active tab for Kantu to run on.


#8

Hi there, basically I have two chrome browsers open – I think it gets confused from time to time – really frustrating

only way to fix it is to close one browser window :frowning: :frowning:

must be some better implementation for this for ppl with dual screens


#10

This is an interesting info, thanks. We will look into this.

If this is indeed the cause of the issue, then there is a good workaround: Use different Chrome profiles. In addition, using different user profiles in Chrome allows you to run several Kantu macros at the same time (one in each profile).


#11

Hello!

I have a same problem. I use Mozilla, only one browser at one time and only one tab. Simple is the best.
The situation is:

  1. I try to clik to a button, which is sometimes not active.
  2. I used !errorignore before and labeled the prev. line of the code ‘_KLIKK’ (in case of error, the code have to start again from here)
  3. After the ClikAndWait with timedout gets an error, but the Gotoif command not works, becouse it can’t find the tab.

Here is the log.

  • [info]
    Executing: | waitForPageToLoad | 3000 | |
  • [info]
    Executing: | label | _KLIKK | |
  • [info]
    Executing: | clickAndWait | id=BUTTON1 | |
  • [error][ignored]
    ‘clickAndWait’ failed. No page load event detected after 10 seconds. Try ‘click’ instead.
  • [info]
    Executing: | gotoIf | !${!statusOK} | _KLIKK |
  • [error][ignored]
    Error #101: Kantu is not connected to a browser tab
  • [info]
    Executing: | clickAndWait | id=BUTTON2 | |
  • [error][ignored]
    Error #101: Kantu is not connected to a browser tab
  • [info]
    Executing: | waitForPageToLoad | 3000 | |
  • [error][ignored]
    Error #101: Kantu is not connected to a browser tab

For handle this error, i have try to put a “SelectWindow | Tab=0” before the Gotoif line, but it not helped, the result was the same.


#12

Hi

I use Kantu from 2 days and i find kantu more powerful and functional.

Your problem is showed when you start a macro from internal page of firefox like about:blank of firefox or from about:config or firefox and similar pages.

You must start macro always form a website already loaded in the tab.

Have a nice day


#13

The script opens a new browser tab with a website url. I think the problem is not the internal page.


#14

Hi @Mora

Sometimes this bug showed to me too, to solve i open a tab with a websites and restart the marcro.

Sometimes this bug showed but do not know the cause.

Have a nice day


#15

Hi @admin @TechSupport

There are news about this bug ?

Does this bug often occur when the final resolution is expected ?

Thanks


#16

Today I have faced this problem for running Kantu overnight.
In the morning I’ve seen multiple errors “Kantu is not connected to a browser tab”.
I tried restart my macros and every time I received “xFile is not installed yet”.
All errors were gone upon full restart of the Chrome.


#17

Hi @commensal

When kantu show “Kantu is not connected to a browser tab” usually in my case open a new tab and try to work in another tab (i never user tab=open) but after some time fail to work.

I don’t understand why kantu try to open new tab (i do not write this in macro) and work in new tab when show “Kantu is not connected to a browser tab” i think that kantu loose the tab numbers and can not control the tabs and open another tab but can not continue the work.

Have a nice day