Command line close=1: Do not close browser when user (manually) stops macro


#1

There is one issue with close=1.
If you opened few tabs and/or want to make change and stop the script manually kantu closes the browser.
That is very annoying. Can you fix this and close it only if suite has done it’s job without human interaction?


Kantu gets slower and slower the longer the script is running
#2

@commensal - I agree, this change makes very good sense.

I understand “…or want to make change and stop the script”

But what do you mean with: “If you opened few tabs…” - did Kantu open the tabs?


#3

Myself. Not Kantu. Usually I ran kantu in incognito mode. And use normal mode for browsing. This closing issue gets in the way. Apart from that Kantu open new tabs (selectWindow) from incognito in normal mode. Another issue. Good timing ask one ignored thread. :blush:
Could you fix that as well? :wink:


#4

And yet the answer is not there. Ok I guess this question will ever be ignored.


#5

We don’t ignore any questions… but we overlook something sometimes :wink:

So let me see if I get it right now:

  1. You run a macro via command line with close=1

  2. Then something happens (e. g. you press stop and want to do some manual work)

  3. And then Kantu closes anyway

Is this the issue?


#6

A post was split to a new topic: Kantu in incognito mode: SelectWindow | tab=open | url) opens normal window (NOT incognito)


#7

1,2,3 yes. With close=1 if I hit stop, not only Kantu closes - the full browser closes (all windows, everything). Regardless of opened pages by Kantu or not.

Ok, that makes good sense. We will change this with the next updates. Once done, pressing “Stop” will disable close=1.