[Closed] Kantu script running too fast


#1

I closed my Kantu window, then later re-opened it. Now my scripts that used to work just fine are failing.

They’re actually running at maximum speed and overrunning the webpage – you can see in this screenshot whre two dropdown fields are open simultaneously.

I tried changing the replay speed from medium to slow (2s) but that still doesn’t solve the problem

Suggestions? Thanks much

BTW, I’m on the XModules version.


#2

XClicks don’t wait for the page to complete something. But you can use

  • visualAssert (image) <= this command does nothing, but only waits for the image to show
  • XClick (image) <= waits for image to show up and then clicks it.

In both cases Kantu waits until it finds the “image”.


#3

Two questions:

  1. What ‘image’? This is a drop-down box

  2. but why doesn’t the “Replay speed” option resolve this? That’s supposed to just wait between commands


#4

Strange. I do not see this issue. Is this in Chrome? I just retested replay and it works for me.

See this screencast: https://www.screencast.com/t/Uw0TC54sgzW


#5

I restarted Chrome; I updated Kantu; I re-installed the extension; I copied all my macros (2) to the hard drive folder and switch to local storage on hard drive mode.

Still failing completely - no intra-command delays.


#6

And I restarted my machine – still no love


#7

If you run the included Demo… macros, do you see the same issue? If yes, a screencast might help us to see what is going on.


#8

I removed extension from Chrome and re-installed; I re-recorded my two scripts. Once or twice, they work, then they start failing with too-fast replay.

Demo scripts seem to work (I tested 4-5 of them)

Could this possible have something to do with Material UI and the fact that their “drop-down” boxes and really plain ol’ divs?


#9

Weird… so I set the replaySpeed first to slow, then back to medum, and now it’s working.

Go figure… thanks!