[Bug report]: xmodule not available after downgrade chrome extension to 3.3.3


#1

Hi I am reporting a bug here.
I have used the Kantu chrome extension and xmodule it worked great.
the bug is that when I downgraded the chrome extension to 3.3.3, then xmodule is gone.
so I downloaded and installed the latest xmodule, but the xmodule will still not show up.
so I uninstalled the xmodule and install again, it is still missing from chrome extension.
but If I install kantu for firefox, right after the installation the xmodule is already in the firefox extension.
My OS is windows 10.
Could you help with this bug?

Thanks!


#2

Can I ask why you downgraded to V3.3.3? The currently available version of XModules is only officially supported for use with Kantu V3.5.5 or later.


#3

my code was written in 3.3.3 and the extension was upgraded to 3.5.5 automatically.
I would like to go back to 3.3.3 so I don’t have to change anything to my code due to the limit of new xmodule.
so you are saying that it is normal that the xmodule will not be used with chrome extension 3.3.3 ?

Thanks!


#4

Just to clarify: The XModule should still work with V3.3.3, but we did not test it. If it does not work, it could be, for example, that a recent Chrome update is causing a problem with the old versions.

For the free/open-source Kantu we officially only support and test the latest version of Kantu with the latest versions of Chrome/Firefox plus the latest XModules version. These combinations alone are already quite a lot of SQA and regression testing work for every release.

For professional use we offer the Kantu Enterprise plan - this includes the option to avoid automatic Chrome extension updates.